Welcart で Advanced Custom Fields が効かなくなった!「2020/08/19」ACFのアップグレードが原因

Welcart

Welcart で Advanced Custom Fieldsを機能させるために、専用のパッチを設置してfunctionに紐付けさせる作業を行いますよね。
つい先日まで機能していたのに、昨日から急に表示されなくなりました。
(これが分からないという方はこちら
設置場所はfunction.phpをおいてある同じ階層に[ wcex_afc_patch.php]をおいて、function.phpに

require(get_theme_file_path(‘/wcex_afc_patch.php’));

を記載すればOK。)

原因はAdvanced Custom Fieldsのバージョン5.9.0

手っ取り早く言えば、Advanced Custom Fieldsのバージョンをダウングレードすれば解決します。
ダウングレードはこちらから
Advanced Custom Fields|downloads

ダウングレードは一つ下の「ACF 5.8.9」で大丈夫です。

こちらをダウンロードしたら、ご自身のサイトのプラグイン項目から「新規追加」で、ダウングレード版のACF5.8.9 Zipファイルのままアップします。

すると、古いバージョンですが大丈夫ですか?といったニュアンスのコメントが出てきますが、無視してダウングレード版を入れます。
これで解決!よかった!

おそらく今回の件でWelcartさんの方で、新しいパッチを追加してくれるのではないかなと思っています。
できればWelcart用ACF みたいなプラグイン作ってくれたら完璧なんですけどね。笑

ピックアップ記事

関連記事一覧

  • コメント ( 0 )

  • トラックバックは利用できません。

  1. この記事へのコメントはありません。